VintAGE-Vans

Would you like to react to this message? Create an account in a few clicks or log in to continue.

BRINGING IT ALL TOGETHER.... A's, G's & E's


3 posters

Ford guys please help!

avatar
Guest
Guest


Ford guys please help! Empty Ford guys please help!

Post by Guest Sat Jul 31, 2010 5:48 am

Can someone please tell me where on a 1973 Ford 351 Cleveland, the temperature sending unit is? A guy I know has a '73 Torino wagon and we can't find it anywhere. The factory temp gauge isn't working and we would like to replace it with an aftermarket underdash gauge. Don't know where the probe enters the engine. It also has AC and it is difficult seeing the surface of the block and intake manifold. Sad I'm a Chevy guy and not of much help. Thanks in advance.
BvrWally
BvrWally


Number of posts : 946
Location : Earlyville,Ohio
Registration date : 2008-05-19

Ford guys please help! Empty Re: Ford guys please help!

Post by BvrWally Sat Jul 31, 2010 6:58 am

Good luck finding it KC!!!
B.W.
RodStRace
RodStRace


Number of posts : 3046
Location : Chino Valley
Registration date : 2010-01-21

Ford guys please help! Empty Re: Ford guys please help!

Post by RodStRace Sat Jul 31, 2010 9:03 am

http://www.banzairunnerpantera.com/updates_thermostat.htm

Temperature Sender Relocation

Therefore, I decided it was time to relocate the temperature sender from the water pump to the correct location in the block, directly beneath the thermostat. There's a 1/2" pipe plug there already, so it was merely a matter of moving the pipe plug to the water pump and moving the temp sender to the block.


Ford guys please help! Temp_sender_relocation
avatar
Guest
Guest


Ford guys please help! Empty Re: Ford guys please help!

Post by Guest Sat Jul 31, 2010 10:38 am

Thanks for the replies. Hope it helps.

Rollie, the wagon is owned by Denny Johnson. You said you met him back in the 70's at his house. Small world.
BvrWally
BvrWally


Number of posts : 946
Location : Earlyville,Ohio
Registration date : 2008-05-19

Ford guys please help! Empty Re: Ford guys please help!

Post by BvrWally Sat Jul 31, 2010 12:56 pm

Wow...yes it is!! Tell him I said Hello! lol Also I still have the Passche set-up he turned me on to!!!! We'll definitely have to get together and have a few IceHouse's!!! lol It's been "WAY" too long!!!!
B.W.
avatar
Guest
Guest


Ford guys please help! Empty Re: Ford guys please help!

Post by Guest Sat Jul 31, 2010 4:22 pm

Rollie,
Denny joined this site as Zinger. There is your link to the past. You can also see him at the Painesville Square car cruise on Friday evenings.
avatar
zinger


Number of posts : 2
Location : mentor, ohio
Registration date : 2010-07-31

Ford guys please help! Empty TEMP SENDING UNIT

Post by zinger Sun Aug 01, 2010 11:38 am

RodStRace: THANKS FOR THE PHOTO, FOUND IT, NOW I NEED TO FIND THE WIRE BECAUSE IT'S DISCONNECTED AND HAS A CAP ON THE PLUG IN. DON'T KNOW WHY. THANKS AGAIN

Sponsored content


Ford guys please help! Empty Re: Ford guys please help!

Post by Sponsored content


    Current date/time is Fri Aug 19, 2022 7:43 pm