BRINGING IT ALL TOGETHER.... A's, G's & E's


Autometer Gas / Fuel Gauge Reading Incorrectly

Share
avatar
66e100pu

Number of posts : 146
Location : So-Cal
Registration date : 2011-04-02

Autometer Gas / Fuel Gauge Reading Incorrectly

Post by 66e100pu on Tue May 21, 2013 4:11 pm

Not sure if this problem came up on this forum or somewhere else, but here goes because somebody will run into it!

I replaced my original tank with a new 20 gal. Mustang unit. I wanted everything new, so I sprang for a reproduction sending unit to go along with my new Autometer gas gauge. After the install I noticed that with a full tank, the gauge was reading over the full mark (fully pegged). While driving the needle barely moved off the full mark until about half the fuel was gone. It would then hang on the ¼ full mark until slowly dropping to below empty when it would finally be out of fuel. When it indicated ¼, it really had ½ a tank left.

If you Google the problem it’s fairly common in the Mustang groups, and there are all kinds of fixes for it (resistors, diodes, and who knows what else). All of these things are just putting a Band-Aid on it and not fixing the root cause of the problem. I finally found a tech bulletin that Autometer put out addressing the problem, and it indicated that ONLY an OEM fuel sending unit will read correctly with their gauge. It seems that the repop senders are “linear” and are not compatible. So I had to source a good used OEM Ford sending unit, drop the tank, and put it all together for the 2nd time. Before I installed it, I hooked it up and held the arm at full, at ½, and empty, and with a minor tweak for the full position, it worked perfectly. I’ve had it installed for about a month now, and FINALLY everything works as it should. I generally never use old mechanical or electrical parts during a build, but in this case it was the only way to go …. Wish I had known before I bought the repop sender! Hope this might help somebody from chasing their tail...
avatar
Baczek

Number of posts : 32
Location : Los Angeles, Ca
Age : 29
Registration date : 2015-05-10

Re: Autometer Gas / Fuel Gauge Reading Incorrectly

Post by Baczek on Tue Nov 22, 2016 10:56 am

I also installed the '69 Mustang 20gal tank. Mine reads half full with 20gal in the tank using an aftermarket sending unit. Are you saying any 60's Ford OEM sending unit will work?

    Current date/time is Sun Sep 24, 2017 4:05 pm